Alte Datenbanken sind nicht kompatibel mit 8.5.1.
#1
Ich hatte die Version 6.9.0.1. unter Windows XP auf einem älteren Computer installiert. Ich habe mir eine eigene umfangreiche Datenbank erarbeitet inkl. Flaggen und Wappen und mit auf meinem neuen Computer mit Windows 7 abgespeichert.
Jetzt musste ich mir eine neue Version 8.5.1. herunterladen, um weiter das Programm nutzen zu können. Leider sind meine alten Datenbanken von 6.9.0.1. nicht mehr kompatibel in 8.5.1..
Was kann ich tun?
Zitieren
#2
2-3 Versionen dazwischen installieren, die entsprechende Datenbank laden, (die DB wird auf diese Version hoch konvertiert) dann die nächste höhere Version installieren.. bist du zu version 8.1 oder so bist..

kann dir leider nicht genau sagen, bis zu welcher version das 6.9. hinauf kompatibel ist. resp. welche version, dass noch 6.9. "hinauf" kompatibel ist.
Nein ich bin nicht die Signatur. Ich sortiere hier nur den Buchstabensalat, den mein Besitzer hier eben fabriziert hat! Für die einen die Signatur - für die anderen der sinnloseste Satz der Welt.
Zitieren
#3
Hallo Didl66,

dazu folgende Frage:
Hast Du Deine Datenbank (oder eine Sicherung davon) schon versucht mit der neuen Version zu öffnen?
Wenn nein, ist das super, keinesfalls (!!!) die Datenbank oder die Datensicherung versuchen zu öffnen.

Wenn Du schon versucht hast sie zu öffnen, wird es sehr schwierig. In diesem Fall könnten durch den Versuch die Datenbank zu öffnen, die Datenbankstrukturen durcheinandergebracht worden sein. Dies könnte zu einem Verlust deiner Daten geführt haben.

Bitte teile Deine Antwort zur vorherigen Frage hier im Forum mit.

Wie bignike schon mitgeteilt, ist im Fall, dass Du bislang nicht versucht hast die Datenbank zu öffnen, ein schrittweises Update auf die aktuelle Programmversion möglich.
Die genaue Anleitung und die erforderlichen Programmversionen würden wir Dir dann per mail zukommen lassen.

Viele Grüße
Mike30
Zitieren
#4
(11.11.2011, 21:34)didl66 link schrieb:Ich hatte die Version 6.9.0.1. unter Windows XP auf einem älteren Computer installiert. Ich habe mir eine eigene umfangreiche Datenbank erarbeitet inkl. Flaggen und Wappen und mit auf meinem neuen Computer mit Windows 7 abgespeichert.
Jetzt musste ich mir eine neue Version 8.5.1. herunterladen, um weiter das Programm nutzen zu können. Leider sind meine alten Datenbanken von 6.9.0.1. nicht mehr kompatibel in 8.5.1..
Was kann ich tun?

ich frage mich immer, warum angebotene Programm Updates nicht genutzt und installiert werden,
das gilt nicht für DFS, sondern für den gesamten PC Bereich.
Das ist sicher ein allgemeine Weisheit und hilft dir jetzt hier nicht weiter, aber das solltest Du in Zukunft beachten
http://www.schwatzgelb.de
Das BVB Fanzine im Internet
_____________________________________________________
Datenbank Westfalenligen, Landesligen, Bezirksliga 8, Kreispokal Dortmund, Unna/Hamm, Westfalenpokal, RegLiga WestSüdw. 1994-2000, Deutsche Amateurmeisterschaften 1950-1998, Oberligen 1945-63, Deutsche Meisterschaften 1945-63,
http://www.dfs-datenbanken.info/deutschland
Zitieren
#5
Hallo bignike und mike30,

ich habe zwar versucht die Datenbanken zu öffnen, aber "Gott sei Dank" habe ich die Dateien außerdem noch auf einem Stick gespeichert. Ich werde also jetzt die Datenbanken auf dem Rechner löschen und neu aufziehen. Es wäre schön, wenn ihr mir die Zwischenversionen per mail schicken könntet. Besten Dank im voraus...

Hallo Hermi,

leider sind mir zwischendurch keine Updates für DFS angeboten worden...
Ich finde das normalerweise eigentlich immer nervig, aber führe die allgemeinen Updates trotzdem immer durch.
Aber, wie gesagt...

Gruß didl66

Zitieren
#6
Version 7.5.1
Version 8.1.1

Diese beiden Versionen sollten reichen.
GMT

Mehr als 90 Datenbanken - und Platz für noch mehr...  Wink
[Bild: dfsdb_info_banner_400_55.png]
Zitieren
#7
Hallo  didl66,

auf jeden Fall solltest Du ein Exemplar deiner Datenbank als Sicherung zurückhalten und nicht versuchen zu öffnen.

GMT hat Dir die beiden Versionen übersandt, die zu Änderungen in der Datenbank führten.
Deinstalliere nun deine Programmversion, dann installierst Du die  Version 7.5.1. Nach Abschluß der Installation öffnest Du die zur Bearbeitung bestimmte Version deiner Datenbank . Sie wird dann vom Programm automatisch angepasst. Das kann je nach Datenumfang etwas dauern.
Wenn sich die Datenbank erfolgreich geöffnet hat, schließt Du diese wieder. Anschließend deinstallierst Du die Version 7.5.1 und installierst danach die Version 8.1.1.
Nach Abschluß der Installation öffnest Du die zuvor bereits einmal geöffnete Datenbank erneut.
Sie wird dann vom Programm erneut automatisch angepasst. Das kann je nach Datenumfang wieder etwas dauern.
Wenn sich die Datenbank erfolgreich geöffnet hat, schließt Du diese wieder. Anschließend deinstallierst Du die Version 8.1.1 und installierst danach die Version 8.5.1. Danach bist Du programmtechnisch up-to-date.

Letzlich notierst Du Dir noch in deinem Kalender für Mai und November 2012, dass Du überprüfen solltest, ob aktuelle Programmversionen zum Download bereitstehen.

Bitte beachte, daß seitens des Programms im Gegensatz zu deinem Betriebssystem kein automatischer Hinweis erfolgt, dass ein Update zum Download bereitsteht.

Allerdings erfolgt im Forum eine deutliche Ankündigung, dass eine neue Programmversion veröffentlicht wurde. Da zudem in der Regel nur zwei Programm-Update im Jahr erfolgen, sollte ein regelmäßiges Update durch die Nutzer kein Problem sein.

Viele Grüße
Mike30
Zitieren
#8
(13.11.2011, 14:43)Mike30 link schrieb:GMT hat Dir die beiden Versionen übersandt, die zu Änderungen in der Datenbank führten.
Kleine Korrektur: Jede neue Programmversion hat bisher Änderungen an der Datenbank durchgeführt.

Aber die beiden sollten ausreichen, um die Migrationsschritte durchführen zu können.
GMT

Mehr als 90 Datenbanken - und Platz für noch mehr...  Wink
[Bild: dfsdb_info_banner_400_55.png]
Zitieren
#9
Besten Dank an alle.
Hat super geklappt-

Gruß didl66
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  "Schlummernde" Datenbanken GMT 8 5.667 25.10.2019, 21:54
Letzter Beitrag: GMT
Lightbulb immer weniger aktuelle Datenbanken LFC_Mike 11 2.902 28.11.2018, 22:00
Letzter Beitrag: LFC_Mike
  Webspace für Datenbanken GMT 2 9.713 27.02.2011, 12:46
Letzter Beitrag: GMT



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste